icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.gefeibio.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

好运11选5 www.706114.com-福彩兑奖上班时间| www.893555.com-乐彩网官方快三| www.968394.com-9场胜负彩开奖结果| www.111694.com-南方彩票下载| www.202779.com-贵州彩票3b-| www.287011.com-盛世彩票吃大赔小| www.400289.com-海南七彩票今天| www.537581.com-乐享彩票网-| www.633022.com-七彩官方网-| www.715101.com-中华神彩下载| www.801603.com-体育彩票终端机兑奖| www.889303.com-彩神软件下载安装| www.966572.com-澳门五分彩-| www.cai8338.com吉林快三出奖结果| www.of95.com-足彩网比分直播| www.06tc.com-彩神技巧-| www.89bm.com-今日福利彩票30期| www.3220.biz-金鹿彩票官方网站| www.9554.loan-海南彩网-| www.75212.com-福彩刮刮乐图片| www.031172.com-九彩彩票是真的吗| www.116171.com-兰州今天快三走势图| www.197686.com-彩票屠龙应该怎么做| www.280006.com-335彩票平台| www.430524.com-葡京彩票下载| www.538695.com-为什么玩彩乐老是输| www.635265.com-飞鱼彩票算法公式| www.749925.com-腾讯分分彩票技巧| www.829862.com-一彩仓库软件| www.910478.com-篮彩分析-| www.970431.com-福彩多久开一次新区| www.kp44.com-快三彩票的概率| www.p31.me-三亚彩票私彩| www.52uf.com-葡京彩票登陆| www.0385.xyz-迪士尼彩乐园网址| www.9020.com-南宁福彩中心地址| www.51252.cc-风彩彩票是真的吗| www.98959.com-结婚彩礼标语| www.070903.com-天天中彩票腾牛网| www.141884.com-广州鸣彩联系电话| www.224515.com-兼职玩快三-| www.306731.com-欢迎使用826购彩| www.383234.com-体彩样票制作| www.629028.com-快三的概率计算公式| www.708038.com-江西时时彩走势| www.793299.com-cp9彩票九-| www.873733.com-上海彩票-| www.978547.com-彩8苹果下载软件| www.mi6.com-爱彩乐网-| www.rc57.com-时时彩出号口诀| www.11kb.com-天福彩票下载| www.89iv.com-私彩七星彩投注网址| www.2759.cc-汉中福彩中心| www.8613.loan-3d彩票模拟投注器| www.65388.com-福彩3d赵公明推荐| www.026557.com-彩票定位胆骗局| www.106286.com-七星彩资料大全| www.185036.com-海拔彩票-| www.258744.com-新浪体彩竞技风暴| www.333558.com-时时彩平台搭建出租| www.412512.com-彩票代理计划员招收| www.520362.com-买彩票的人都是穷人| www.593788.com-七彩投-| www.670011.com-海南七乐彩合法吗| www.750022.com-福彩网易彩快3| www.821116.com-体彩排列5开结果| www.893728.com-恒彩手机客户端下载| www.965417.com-彩票97平台-| 天天乐彩票www.676285.com| www.jq67.com-股票和快三是赌博吗| www.f61.cn-华彩官方登陆| www.39id.com-广西彩调-| www.1570.tv-彩想和彩宝的区别| www.8389.pw-台湾七星彩全年资料| www.32959.cc-体彩19048期| www.77353.cc-山东体彩手机购彩| www.029588.cc-滴滴彩票app| www.099582.com-百盈互动彩票| www.155437.com-中国体育彩票飞鱼彩| www.317882.com-永利彩票-| www.387217.com-查今天福彩中奖号码| www.554329.com-网易彩票骗局| www.622526.com-ios系统购彩软件| www.696400.com-竞彩资讯专家| www.773209.com-免费送彩金188| www.939257.com-足彩开奖查询| www.991984.com-彩先知彩票精准大师| tem.big.content福彩3d阴阳走势图| www.pb80.com-快三倍投是不是必死| www.00oc.com-中国彩票今晚| www.70jx.com-买彩票诗句-| www.0898.net-华夏彩票怎么玩| www.8739.biz-华南地区七星彩论坛| www.41896.com-3d真福彩早早报| www.87384.com-933彩票安卓下载| www.041369.com-体彩福福彩开奖结果| www.144583.com-胆略足彩竞彩分析| www.233008.com-北京福彩3d论坛| www.305769.com-彩票可以一次买几期| www.376685.com-体彩助手官网| www.519805.com-往期中奖彩票被调| www.588748.com-新浪彩网开奖号| www.659526.com-2016足彩app| www.766493.com-彩客彩票三分二28| www.841602.com-彩妆盘淘宝代购| www.905306.com-江西快三84期开奖| www.961012.cc-3d彩综合走势图| 500万彩票www.48wcp.com| www.ca67.com-彩票知识讲解| www.sj83.com-最新彩票开奖信息| www.16ue.com-彩天下是诈骗| www.95ix.com-北京快3福彩自助| www.2576.vip-中信积分的彩票入口| www.7893.cc-黄金彩票-| www.24336.com-福彩开奖的真实性| www.66137.cc-彩票大师下载软件| www.117330.com-破解彩票数字规律题| www.183659.com-福利彩票河北快3| www.252508.com-99彩票害人不浅| www.318499.com-重庆彩平刷-| www.381651.com-天天竞猜足球彩票| www.543563.com-鄂尔多斯体彩中心| www.621982.com-福彩欢乐十选五| www.686070.com-彩票限号一般会开吗| www.761155.com-体彩销售截止时间| www.855218.com-极速彩平台-| www.902416.com-天天买彩票下载| www.954912.com-凤凰彩票快三开挂| www.994126.com-上海快三共有多少期| www.cp4858.cc-uu快三骗局揭秘| www.lc08.cc-多多彩票app下载| www.c19.shop-北京快三打法| www.26tp.com-电子彩票端口| www.968.gg-g500购彩平台| www.5750.pw-体彩七位数中四位| www.04770.com-足彩怎么买最合理| www.45488.com-七乐彩中奖查询一| www.86768.cc-福建丹青快三| www.033517.com-彩川ひなの番号| www.153288.com-大公鸡七星彩奖表| www.232324.com-上海快三基本走势| www.296535.com-体彩31走势图| www.361629.com-鸿辰国际彩票app| www.442881.com-近期双彩球开奖结果| www.526813.com-彩票分析师工资| www.645310.com-彩网高手论坛| www.720909.com-乐彩网p3专家| www.786556.com-极速分分彩票| www.854074.com-安徽快三奖励| www.898889.com-9亿彩票首页| www.949816.com-炫乐彩票合法吗| www.984206.com-福彩自助app下载| www.wj89.com-幸运快三如何看走势| www.05gp.com-渐变花朵彩铅片| www.65hf.com-乐盛彩票-| www.0014.cc-十二生肖的彩票开奖| www.7222.com-彩虹7号游戏| www.16316.cc-网易彩票安全可靠吗| www.53292.cc-正规最大时时彩平台| www.90093.cc-七彩影院app| www.034945.com-71彩票首页| www.146901.com-凤凰彩票插件| www.223171.com-3d福彩试机号| www.284895.com-时时彩如何追杀客户|